Splunk Enterprise 6.2.3 and Splunk Light 6.2.3 address five vulnerabilities

Table of Contents

Description

Splunk Enterprise 6.2.3 and Splunk Light 6.2.3 address five vulnerabilities.

At the time of this announcement, Splunk is not aware of any cases where these vulnerabilities have been actively exploited. Previous Product Security Announcements can be found on our Splunk Product Security Portal. Use SPL numbers when referencing issues in communication with Splunk. If there is no CVE Identifier listed with a vulnerability, it will be added once it is assigned by a CVE Numbering Authority. To standardize the calculation of severity scores for each vulnerability, when appropriate, Splunk uses Common Vulnerability Scoring System version 2.

Affected Products and Components

  • Multiple vulnerabilities in OpenSSL prior to 1.0.1m (SPL-98351)
    • Affected Versions: Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light 6.2.x before 6.2.3.
    • Affected Components: All Splunk components.
  • Disable SSLv3 in KV Store Replication (SPL-96280)
    • Affected Versions: These vulnerabilities affect all versions of Splunk Enterprise 6.2.x before 6.2.3.
    • Unaffected Versions: These vulnerabilities do not affect Splunk Enterprise 5.0.x, 6.0.x, 6.1.x. or Splunk Light.
    • Affected Components: Search Head in Search Head Cluster Configurations.
    • Affected Components: Heavy Forwarders, Universal Forwarders, Indexers, Deployment Servers.
  • Secure flag inconsistently set for session cookies when appServerPorts!=0 (SPL-95798)
    • Affected Versions: These vulnerabilities affect all versions of Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light before 6.2.3.
    • Unaffected Versions: These vulnerabilities do not affect Splunk Enterprise 5.0.x, 6.0.x, 6.1.x.
    • Affected Components: Search Heads, Heavy Forwarders with Splunk Web enabled.
    • Unaffected Components: Indexers, Deployment Server, Universal Forwarders.
  • Cross-site scripting in Search (SPL-95594)
    • Affected Versions: These vulnerabilities affect all versions of Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light before 6.2.3.
    • Unaffected Versions: These vulnerabilities do not affect Splunk Enterprise 5.0.x, 6.0.x, 6.1.x.
    • Affected Components: Search Heads, Heavy Forwarders with Splunk Web enabled.
    • Unaffected Components: Indexers, Deployment Server, Universal Forwarders.
  • Cross-site scripting in management and configuration (SPL-93516)
    • Affected Versions: These vulnerabilities affect all versions of Splunk Enterprise 6.2.x before 6.2.3, 6.1.x before 6.1.7, 6.0.x before 6.0.9, 5.0.x before 5.0.12, and Splunk Light before 6.2.3.
    • Unaffected Versions: These vulnerabilities do not affect Splunk Enterprise 5.0.10, 6.0.x, 6.1.x.
    • Affected Components: Search Heads, Heavy Forwarders with Splunk Web enabled.
    • Unaffected Components: Indexers, Deployment Server, Universal Forwarders.

    Mitigation and Upgrades

    To mitigate these issues, Splunk recommends upgrading to the latest release and applying as many of the Hardening Standards from the Securing Splunk documentation as are relevant to your environment. Splunk Enterprise releases are cumulative, meaning that future releases will contain fixes to these vulnerabilities, new features and other bug fixes.

    Vulnerability Descriptions and Ratings

    Multiple vulnerabilities in OpenSSL before 1.0.1m (SPL-98531)

    Description: Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light 6.2.x before 6.2.3 are affected by multiple OpenSSL vulnerabilities resolved by OpenSSL 1.0.1m. The most severe of these issues could result in a crash during TLS connections.

    Note: OpenSSL upgrades for other versions of Splunk Enterprise will be shipped in future maintenance releases.

    CVSS Severity (version 2.0):

    CVSS Base Score 2.6
    CVSS Impact Subscore 2.9
    CVSS Exploitability Subscore 4.9
    Overall CVSS Score 2.6

    Disable SSLv3 in KV Store replication (SPL-96280)

    Description: In search head cluster configurations of Splunk Enterprise 6.2.x, KV store provided no method for disabling SSLv3. This could permit a man-in-the-middle attacker to force a downgrade to SSLv3 between members of the search head cluster's KV store replication protocol.

    CVSS Severity (version 2.0):

    CVSS Base Score 5.1
    CVSS Impact Subscore 6.9
    CVSS Exploitability Subscore 4.9
    Overall CVSS Score 5.1

    Secure flag inconsistently set for session cookies with appServerPorts!=0 (SPL-95798)

    Description: When using Splunk Web with SSL enabled, the secure flag is not consistently set for all URL paths. This vulnerability affects versions of Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light before 6.2.3. This vulnerability could lead to leaking session cookies over HTTP when a user visits specific URLs.

    CVSS Severity (version 2.0):

    CVSS Base Score 5.4
    CVSS Impact Subscore 6.9
    CVSS Exploitability Subscore 5.4
    Overall CVSS Score 6.8

    Cross-site scripting in Search (SPL-95594)

    Description: The Splunk Enterprise 6.2.x search functionality contains a cross-site scripting vulnerability. This can be triggered by user-interaction or via malicious search data.This vulnerability affects versions of Splunk Enterprise 6.2.x before 6.2.3 and Splunk Light before 6.2.3. This vulnerability could lead to leaking session cookies over HTTP when a user visits a series of attacker controlled URLs.

    Credit

    Splunk would like to thank Cisco CSIRT team for the privately reporting this vulnerability.

    CVSS Severity (version 2.0):

    CVSS Base Score 8.8
    CVSS Impact Subscore 9.2
    CVSS Exploitability Subscore 8.6
    Overall CVSS Score 8.8

    Cross-site scripting in management and configuration (SPL-93516)

    Description: Splunk Enterprise 6.2.x before 6.2.3, 6.1.x before 6.1.7, 6.0.x before 6.0.8, and 5.0.x before 5.0.12 and Splunk Light before 6.2.3 contain a reflected cross-site scripting vulnerability in the management and configuration pages. This could allow an attacker to perform actions in the user context via a crafted URL.

    CVSS Severity (version 2.0):

    CVSS Base Score 8.8
    CVSS Impact Subscore 9.2
    CVSS Exploitability Subscore 8.6
    Overall CVSS Score 8.8