Splunk Enterprise 6.4.2, 6.3.6, 6.2.11, 6.1.11, 6.0.12, 5.0.16 and Splunk Light 6.4.2 address multiple security vulnerabilites

Table of Contents

Description

Splunk Enterprise 6.4.2, 6.3.6, 6.2.11, 6.1.11, 6.0.12, 5.0.16 and Splunk Light 6.4.2 address multiple security vulnerabilites

At the time of this announcement, Splunk is not aware of any cases where these vulnerabilities have been actively exploited. Previous Product Security Announcements can be found on our Splunk Product Security Portal. Use SPL numbers when referencing issues in communication with Splunk. If there is no Common Vulnerabilities and Exposures (CVE) identifier listed with a vulnerability, it will be added once it is assigned by a CVE Numbering Authority. To standardize the calculation of severity scores for each vulnerability, when appropriate, Splunk uses Common Vulnerability Scoring System version 2 (CVSS v2).

Affected Products and Components

  • Multiple vulnerabilities in OpenSSL before 1.0.1t and 1.0.2h (SPL-119440)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12 and Splunk Light before 6.4.2
    • Affected Components: All Splunk Enterprise components.
  • Multiple vulnerabilities in libarchive before 3.2.1 (SPL-123095)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.11, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2
    • Affected Components: All Splunk Enterprise components.
  • Multiple vulnerabilities in libxml2 prior to 2.9.4 (SPL-121159)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2
    • Affected Components: All Splunk Enterprise components.
  • Open redirect in Splunk Web (SPL-119464)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.11 and Splunk Light before 6.4.2
    • Affected Components: All Splunk Enterprise components running Splunk Web.
  • Cross-Site Scripting Vulnerability in Splunk Web (SPL-118666)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2
    • Affected Components: All Splunk Enterprise components running Splunk Web.

    Mitigation and Upgrades

    To mitigate these issues, Splunk recommends upgrading to the latest release and applying as many of the Hardening Standards from the Securing Splunk documentation as are relevant to your environment. Splunk Enterprise and Splunk Light releases are cumulative, meaning that future releases will contain fixes to these vulnerabilities, new features and other bug fixes.

    Vulnerability Descriptions and Ratings

    Multiple vulnerabilities in OpenSSL before 1.0.1t and 1.0.2h (SPL-119440)

    Description: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12 and Splunk Light before 6.4.2 are affected by OpenSSL vulnerabilities (advisory) including incorrect protection against padding-oracle attacks on CPUs supporting the AES-NI instruction (CVE-2016-2107).

    Notes: Splunk Enterprise 5.0.x will not be patched for OpenSSL issues. Splunk recommends updating to the latest version of Splunk Enterprise.

    Multiple vulnerabilities in libarchive before 3.2.1 (SPL-123095)

    Description: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.11, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2 are affected by multiple vulnerabilities (1, 2, 3) in libarchive prior to 3.2.1. The exploitation of issues could permit an attacker with write ability to a monitored file location to execute code in the local instance of splunkd.

    Credits: Cisco Talos

    Multiple vulnerabilities in libxml2 prior to 2.9.4 (SPL-121159)

    Description: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2 are affected by multiple vulenrabilities in libxml2 prior to libxml 2.9.4.

    Open redirect in Splunk Web (SPL-119464)

    Description: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.11 and Splunk Light before 6.4.2 are affected by a vulnerability that could permit an attacker to redirect user to an attacker controlled website..

    Credits: Noriaki Iwasaki (Cyber Defense Institute, Inc.)

    CVSS Severity (version 2.0):

    CVSS Base Score5.0
    CVSS Impact Subscore2.9
    CVSS Exploitability Subscore10
    Overall CVSS Score5.0

    Cross-Site Scripting Vulnerability in Splunk Web (SPL-118666)

    Description: Splunk Enterprise versions 6.4.x before 6.4.2, 6.3.x before 6.3.6, 6.2.x before 6.2.10, 6.1.x before 6.1.11, 6.0.x before 6.0.12, 5.0.x before 5.0.16 and Splunk Light before 6.4.2 are affected by a cross-site scripting vulnerability in Splunk Web. This vulnerability is only known to affect users using Internet Explorer.

    Credits: Noriaki Iwasaki (Cyber Defense Institute, Inc.), Vipul Bhagwanrao Patil

    CVSS Severity (version 2.0):

    CVSS Base Score8.8
    CVSS Impact Subscore4.9
    CVSS Exploitability Subscore8.6
    Overall CVSS Score5.8