Splunk Enterprise and Splunk Light address multiple vulnerabilities

Table of Contents

Description

Splunk Enterprise and Splunk Light address multiple vulnerabilities

At the time of this announcement, Splunk is not aware of any cases where these vulnerabilities have been actively exploited. Previous Product Security Announcements can be found on our Splunk Product Security Portal. Use SPL numbers when referencing issues in communication with Splunk. If there is no Common Vulnerabilities and Exposures (CVE) identifier listed with a vulnerability, it will be added once it is assigned by a CVE Numbering Authority. To standardize the calculation of severity scores for each vulnerability, when appropriate, Splunk uses Common Vulnerability Scoring System version 3.0 (CVSS v3.0).

Affected Products and Components

  • Cross Site Scripting in Splunk Web (CVE-2018-7427)
    • Affected Product Versions: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.7, 6.3.x before 6.3.10, 6.2.x before 6.2.14, 6.1.x before 6.1.13, 6.0.x before 6.0.14 and Splunk Light before 6.6.0
    • Affected Components: All Splunk Enterprise components running Splunk Web.
  • Denial of Service (CVE-2018-7432)
    • Affected Product Versions: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.7, 6.3.x before 6.3.10, 6.2.x before 6.2.14 and Splunk Light before 6.6.0
    • Affected Components: All Splunk Enterprise components running Splunk Web.
  • Path Traversal Vulnerability in Splunk Django App (CVE-2018-7431)
    • Affected Product Versions: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.6, 6.3.x before 6.3.10, 6.2.x before 6.2.14, 6.1.x before 6.1.13, 6.0.x before 6.0.14 and Splunk Light before 6.6.0
    • Affected Components: All Splunk Enterprise components running Splunk Web.
  • Splunkd Denial of Service via Malformed HTTP Request (CVE-2018-7429)
    • Affected Product Versions: Splunk Enterprise versions 6.4.x before 6.4.8, 6.3.x before 6.3.11, 6.2.x before 6.2.14 and Splunk Light before 6.5.0
    • Affected Components: All Splunk Enterprise components running Splunk Web.

    Mitigation and Upgrades

    To mitigate these issues, Splunk recommends upgrading to the latest release and applying as many of the Hardening Standards from the Securing Splunk documentation as are relevant to your environment. Splunk Enterprise and Splunk Light releases are cumulative, meaning that future releases will contain fixes to these vulnerabilities, new features and other bug fixes.

    Vulnerability Descriptions and Ratings

    Cross Site Scripting in Splunk Web (CVE-2018-7427)

    Description: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.7, 6.3.x before 6.3.10, 6.2.x before 6.2.14, 6.1.x before 6.1.13, 6.0.x before 6.0.14 and Splunk Light before 6.6.0 are affected by a cross-site scripting vulnerability in Splunk Web.

    CVSS Severity (version 3.0):

    CVSS Base Score8.1
    CVSS Impact Subscore5.2
    CVSS Exploitability Subscore2.8
    Overall CVSS Score8.1

    Denial of Service (CVE-2018-7432)

    Description: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.7, 6.3.x before 6.3.10, 6.2.x before 6.2.14 and Splunk Light before 6.6.0 are affected by a denial of service condition when Splunkd receives a specially crafted HTTP request.

    Credits: Splunk would like to thank Robert Dunn for reporting this issue.

    CVSS Severity (version 3.0):

    CVSS Base Score6.5
    CVSS Impact Subscore3.6
    CVSS Exploitability Subscore2.8
    Overall CVSS Score6.5

    Path Traversal Vulnerability in Splunk Django App (CVE-2018-7431)

    Description: Splunk Enterprise versions 6.5.x before 6.5.3, 6.4.x before 6.4.6, 6.3.x before 6.3.10, 6.2.x before 6.2.14, 6.1.x before 6.1.13, 6.0.x before 6.0.14 and Splunk Light before 6.6.0 are affected by a vulnerability that allows an authenticated attacker to download arbitary files from Splunk Django App through directory traversal attack.

    CVSS Severity (version 3.0):

    CVSS Base Score6.8
    CVSS Impact Subscore4.0
    CVSS Exploitability Subscore2.3
    Overall CVSS Score6.8

    Splunkd Denial of Service via Malformed HTTP Request (CVE-2018-7429)

    Description: Splunk Enterprise versions 6.4.x before 6.4.8, 6.3.x before 6.3.11, 6.2.x before 6.2.14 and Splunk Light before 6.5.0 are affected by a denial of service condition when Splunkd receives a specially crafted HTTP request.

    CVSS Severity (version 3.0):

    CVSS Base Score7.5
    CVSS Impact Subscore3.6
    CVSS Exploitability Subscore3.9
    Overall CVSS Score7.5