Splunk Enterprise versions 6.0.7 and 5.0.11 address three vulnerabilities

Table of Contents

Description

Splunk Enterprise versions 6.0.7 and 5.0.11 address three vulnerabilities

At the time of this announcement, Splunk is not aware of any cases where these vulnerabilities have been actively exploited. Previous Product Security Announcements can be found on our Splunk Product Security Portal. Use SPL numbers when referencing issues in communication with Splunk. If there is no CVE Identifier listed with a vulnerability, it will be added once it is assigned by a CVE Numbering Authority. To standardize the calculation of severity scores for each vulnerability, when appropriate, Splunk uses Common Vulnerability Scoring System version 2.

Affected Products and Components

  • OpenSSL session ticket memory leak (SPL-91947, CVE-2014-3567)
    • Affected versions: All versions of Splunk Enterprise 6.0.x before 6.0.7, and 5.0.x before 5.0.11.
    • This does affect: All Splunk components.
  • TLS protocol enhancements related to POODLE (SPL-92062, CVE-2014-3566)
    • Affected versions: All versions of Splunk Enterprise 6.0.x before 6.0.7, and 5.0.x before 5.0.11.
    • This does affect: All Splunk components.
  • Persistent cross-site scripting (XSS) via Dashboard (SPL-89216, CVE-2014-5466)
    • Affected versions: All versions of Splunk Enterprise 6.1.x before 6.1.4, 6.0.x before 6.0.7, and 5.0.x before 5.0.10.
    • This does not affect: universal forwarders.
    • This does affect: search heads, heavy forwarders with Splunk Web enabled, and indexers with Splunk Web enabled.

Mitigation and Upgrades

To mitigate these issues, Splunk recommends upgrading to the latest release and applying as many of the Hardening Standards from the Securing Splunk documentation as are relevant to your environment. Splunk Enterprise releases are cumulative, meaning that future releases will contain fixes to these vulnerabilities, new features and other bug fixes.

Vulnerability Descriptions and Ratings

OpenSSL session ticket memory leak (SPL-91947, CVE-2014-3567)

Description: OpenSSL versions before 1.0.1j and 0.9.8zc do not properly handle invalid session tickets. When encountering an invalid session ticket, OpenSSL fails to free memory. This vulnerability could be used to cause a Denial of Service to Splunk Enterprise.

CVSS Severity (version 2.0):

CVSS Base Score 4.3
CVSS Impact Subscore 2.9
CVSS Exploitability Subscore 8.6
Overall CVSS Score 4.3

TLS protocol enhancements related to POODLE (SPL-92062, CVE-2014-3566)

Description: Due to weaknesses in SSLv3, including the POODLE attack, Splunk Enterprise has added the sslVersions attribute to allow administrators to control what versions of TLS/SSL are supported. For further information, refer to the Splunk Enterprise 6.0.7 Documentation and Splunk Enterprise 5.0.11 Documentation. Additionally, TLS_FALLBACK_SCSV support is now included to mitigate browser downgrade attacks.

CVSS Severity (version 2.0):

CVSS Base Score 4.3
CVSS Impact Subscore 2.9
CVSS Exploitability Subscore 8.6
Overall CVSS Score 4.3

Persistent cross-site scripting (XSS) in Dashboard (SPL-89216, CVE-2014-5466)

Description: Persistent cross-site scripting (XSS) dashboard vulnerability in Splunk Web in Splunk Enterprise 6.1.x before 6.1.4, 6.0.x before 6.0.7, and 5.0.x before 5.0.10 allows remote attackers to inject arbitrary script. This vulnerability had previously been inadvertantly stated as fixed in Splunk Enterprise 6.0.6.

Credit

Splunk would like to thank Adam Bell / Lateral Security for the the responsible disclosure of issue SPL-89216.


CVSS Severity (version 2.0):

CVSS Base Score 6.5
CVSS Impact Subscore 6.4
CVSS Exploitability Subscore 8.0
Overall CVSS Score 6.5