Splunk Enterprise 6.2.5, 6.1.9, 6.0.10, 5.0.14 and Splunk Light 6.2.5 address multiple vulnerabilities

Table of Contents

Description

Splunk Enterprise 6.2.5, 6.1.9, 6.0.10, 5.0.14 and Splunk Light 6.2.5 address multiple vulnerabilities

At the time of this announcement, Splunk is not aware of any cases where these vulnerabilities have been actively exploited. Previous Product Security Announcements can be found on our Splunk Product Security Portal. Use SPL numbers when referencing issues in communication with Splunk. If there is no Common Vulnerabilities and Exposures (CVE) Identifier listed with a vulnerability, it will be added once it is assigned by a CVE Numbering Authority. To standardize the calculation of severity scores for each vulnerability, when appropriate, Splunk uses Common Vulnerability Scoring System version 2 (CVSS v2).

Affected Products and Components

  • Multiple vulnerabilities in OpenSSL versions before 1.0.1p and 0.9.8zg (SPL-103044)
    • Affected Product Versions: Splunk Enterprise 6.2.x before 6.2.5, 6.1.x before 6.1.9, 6.0.x before 6.0.10, 5.0.x before 5.0.14 and Splunk Light 6.2.x before 6.2.5
    • Affected Components: Affected Components: All Splunk Enterprise components.
  • Reflected cross-site scripting in Splunk Web (SPL-102133)
    • Affected Product Versions: Splunk Enterprise 6.0.x before 6.0.9 and 5.0.x before 5.0.14
    • Affected Components: Search Heads, Any component with Splunk Web enabled.
    • Unaffected Components: All components with Splunk Web disabled.

    Mitigation and Upgrades

    To mitigate these issues, Splunk recommends upgrading to the latest release and applying as many of the Hardening Standards from the Securing Splunk documentation as are relevant to your environment. Splunk Enterprise and Splunk Light releases are cumulative, meaning that future releases will contain fixes to these vulnerabilities, new features and other bug fixes.

    Vulnerability Descriptions and Ratings

    Multiple vulnerabilities in OpenSSL versions before 1.0.1p and 0.9.8zg (SPL-103044)

    Description: Splunk Enterprise versions 6.2.x before 6.2.5, 6.1.x before 6.1.8, 6.0.x before 6.0.9, 5.0.x before 5.0.14, and Splunk Light 6.2.x before 6.2.5 are affected by multiple OpenSSL vulnerabilities [1] [2]. These issues are resolved with OpenSSL versions 1.0.1p and 0.9.8zg.

    CVSS Severity (version 2.0):

    CVSS Base Score 4.3
    CVSS Impact Subscore 2.9
    CVSS Exploitability Subscore 8.6
    Overall CVSS Score 4.3

    Reflected cross-site scripting in Splunk Web (SPL-102133)

    Description: A reflected cross-site scripting vulnerability in Splunk Enterprise 6.0.x before 6.0.10 and 5.0.x before 5.0.14 could permit a remote user to inject arbitrary JavaScript via a malicious URL.

    CVSS Severity (version 2.0):

    CVSS Base Score 3.6
    CVSS Impact Subscore 4.9
    CVSS Exploitability Subscore 3.9
    Overall CVSS Score 3.6