Skip to main content

SPLUNK / PRODUCT SECURITY / SVD-2022-1109

Persistent Cross-Site Scripting via a Data Model object name in Splunk Enterprise

Advisory ID: SVD-2022-1109

Published: 2022-11-02

CVSSv3.1 Score: 8.0, High

CWE: CWE-79

CVE ID: CVE-2022-43569

Last Update: 2022-11-02

CVSSv3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Bug ID: SPL-228087

Description

In Splunk Enterprise versions below 8.1.12, 8.2.9, and 9.0.2, an authenticated user can inject and store arbitrary scripts that can lead to persistent cross-site scripting (XSS) in the object name of a Data Model.

Solution

For Splunk Enterprise, upgrade versions to 8.1.12, 8.2.9, 9.0.2, or higher.

For Splunk Cloud Platform, Splunk is actively patching and monitoring the Splunk Cloud instances.

Product Status

ProductVersionComponentAffected VersionFixed Version
Splunk Enterprise8.1Splunk Web8.1.11 and lower8.1.12
Splunk Enterprise8.2Splunk Web
8.2.0 to 8.2.88.2.9
Splunk Enterprise9.0Splunk Web
9.0.0 to 9.0.19.0.2
Splunk Cloud Platform-Splunk Web
9.0.2208 and lower9.0.2209

Mitigations and Workarounds

The vulnerability affects instances with Splunk Web enabled, disabling Splunk Web is a possible workaround. See Disable unnecessary Splunk Enterprise components and the web.conf configuration specification file for more information on disabling Splunk Web.

Detections

Splunk Stored XSS via Data Model objectName field

This detection search provides information on exploitation attempts against vulnerable instances in Splunk Enterprise versions 8.1.12, 8.2.9, and 9.0.2 via persistent cross site scripting via a Data Model object name.

Severity 

Splunk rates the vulnerability as High, 8.0, with a CVSS Vector of CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H. The vulnerability requires user access to create a Data Model. If the Splunk Enterprise instance does not run Splunk Web, there is no impact and the severity is Informational.

Acknowledgments

Danylo Dmytriiev (DDV_UA)

Questions? Submit your question to Splunk Support.