Advisory ID: SVD-2022-1108
CVSSv3.1 Score: 8.8, High
CVE ID: CVE-2022-43568
Last Update: 2022-11-02
CVSSv3.1 Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Bug ID: SPL-228379
For Splunk Enterprise, upgrade versions to 8.1.12, 8.2.9, 9.0.2, or higher.
For Splunk Cloud Platform versions below 9.0.2205, Splunk is actively patching and monitoring the Splunk Cloud instances. To request an immediate upgrade, determine which version of Splunk Cloud Platform you're running, then create a new support case.
|Product||Version||Component||Affected Version||Fixed Version|
|Splunk Enterprise||8.1||Splunk Web||8.1.11 and lower||8.1.12|
|Splunk Enterprise||8.2||Splunk Web||8.2.0 to 8.2.8||8.2.9|
|Splunk Enterprise||9.0||Splunk Web||9.0.0 to 9.0.1||9.0.2|
|Splunk Cloud Platform||-||Splunk Web||9.0.2203.4 and lower||9.0.2205|
Mitigations and Workarounds
The vulnerability affects instances with Splunk Web enabled, disabling Splunk Web is a possible workaround. See Disable unnecessary Splunk Enterprise components and the web.conf configuration specification file for more information on disabling Splunk Web.
Splunk Reflected XSS in the templates lists radio
Splunk versions 8.1.0, 8.2.0, and 9.0.0 are vulnerable to reflected cross site scripting (XSS) exploitation leading to Local File Inclusion (LFI) in the Splunk Assist application. This detection search provides information on exploitation attempts.
Splunk rates the vulnerability as High, 8.8, with a CVSS Vectors of CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H. The vulnerability requires user interaction within a browser. If the Splunk Enterprise instance does not run Splunk Web, there is no impact and the severity is Informational.
Danylo Dmytriiev (DDV_UA)