Skip to main content

SPLUNK / PRODUCT SECURITY / SVD-2022-1101

Persistent Cross-Site Scripting in “Save Table” Dialog in Splunk Enterprise

Advisory ID: SVD-2022-1101

Published: 2022-11-02

CVSSv3.1 Score: 6.4, M 6.4, Medium

CWE: CWE-79

CVE ID: CVE-2022-43561

Last Update: 2022-11-02

CVSSv3.1 Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H

Bug ID: SPL-207040

Description

In Splunk Enterprise versions below 8.1.12, 8.2.9, and 9.0.2, a remote user that holds the “power” Splunk role can store arbitrary scripts that can lead to persistent cross-site scripting (XSS). The vulnerability affects instances with Splunk Web enabled.

Solution

For Splunk Enterprise, upgrade versions to 8.1.12, 8.2.9, 9.0.2, or higher.


For Splunk Cloud Platform versions below 9.0.2208, Splunk is actively patching and monitoring the Splunk Cloud instances. To request an immediate upgrade, determine which version of Splunk Cloud Platform you're running, then create a new support case.


Product Status

ProductVersionComponentAffected VersionFixed Version
Splunk Enterprise8.1Splunk Web8.1.11 and lower8.1.12
Splunk Enterprise8.2Splunk Web
8.2.0 to 8.2.88.2.9
Splunk Enterprise9.0Splunk Web9.0.0 to 9.0.19.0.2
Splunk Cloud Platform
Splunk Web9.0.2205 and lower9.0.2208


Mitigations and Workarounds

If users do not log in to Splunk Web on indexers in a distributed environment, disable Splunk Web on those indexers. See Disable unnecessary Splunk Enterprise components and the web.conf configuration specification file for more information on disabling Splunk Web.

Detections

Splunk XSS in “Save Table” dialog header in search/table page

This is a detection search to find persistent XSS that was included while inputting data in the 'Save Table' dialog in the affected versions of  Splunk Enterprise.

Severity

Splunk rated the vulnerability as Medium. The vulnerability lets a remote authenticated user with the power role to store arbitrary scripts, but exploitation requires a multistep process by the victim. Hence, Splunk scored the vulnerability as 6.4 with a CVSSv3.1 vector of CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H.


If the Splunk Enterprise instance does not run Splunk Web, there is no impact and the severity is Informational.


Acknowledgments

Mr Hack (try_to_hack)


Questions? Submit your question to Splunk Support.